Degraded Performance - Crowdtap
Incident Report for Suzy
Resolved
Platform appears to be operational again. Crowdtap is functioning as expected.
Posted Apr 30, 2024 - 14:30 EDT
Investigating
We are currently experiencing degraded performance on Crowdtap and currently investigating this issue.
Posted Apr 30, 2024 - 14:02 EDT
This incident affected: Crowdtap (Crowdtap Mobile, Crowdtap Desktop).